Hirdetés

Hirdetés

Új hozzászólás Aktív témák

  • zex

    aktív tag

    Noip-vel szenvedek egy ideje. Adott az alábbi script:

    # No-IP automatic Dynamic DNS update
    #--------------- Change Values in this section to match your setup ------------------
    # No-IP User account info
    :local noipuser <noipusername>
    :local noippass <noippass>
    # Set the hostname or label of network to be updated.
    # Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
    # To specify multiple hosts, separate them with commas.
    :local noiphost <noiphost>
    # Change to the name of interface that gets the dynamic IP address
    :local inetinterface <waninterface>
    #------------------------------------------------------------------------------------
    # No more changes need
    :global previousIP
    :if ([/interface get $inetinterface value-name=running]) do={
    # Get the current IP on the interface
       :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]
    # Strip the net mask off the IP address
       :for i from=( [:len $currentIP] - 1) to=0 do={
           :if ( [:pick $currentIP $i] = "/") do={ 
               :set currentIP [:pick $currentIP 0 $i]
           } 
       }
       :if ($currentIP != $previousIP) do={
           :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
           :set previousIP $currentIP
    # The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
           :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
           :local noiphostarray
           :set noiphostarray [:toarray $noiphost]
           :foreach host in=$noiphostarray do={
               :log info "No-IP: Sending update for $host"
               /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt") 
               :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
           }
       }  else={
           :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
       }
    } else={
       :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
    }

    Frankón működik is, ha a terminálból futtatom. Értem ezalatt azt, hogy a LOG-ba szépen bekerül, hogy nem történt változás az IP-ben, így nincs teendője.

    Ellenben ha a scriptet egy scheduler-el futtatom le, akkor minden egyes esetben a LOG-ba bekerül, hogy megváltozott az IP-m, ezért módosítás történt, majd letölti a .txt fájlt újból, ami tartalmazza a WAN IP-t. Azért zavar, mert ahelyett, hogy csak ellenőriz, minden esetben ír is a belső memóriába, ami félek, hogy rövid idő alatt a tárhely halálához fog vezetni. Nem mellesleg a LOG-ot is teleszemeteli, ahelyett, hogy csak 1 sort írna be. Van valakinek tippje, hogy ezt mi okozhatja? :U

    [ Szerkesztve ]

Új hozzászólás Aktív témák