Hozzászólok Aktív témák

  • Batman

    őstag

    Na ujabb két info, mplayerben az összes vo kimenetre szaggat és más lejatszó is , vlc-t próbáltam.

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Batman

    őstag

    Megintcsak ujabb info. Nem az mplayer környékén kell keresni a hibat, maga az egész gép beszaggat.

    Opera-ban és firefoxban szinten lassu a tabok közti váltás, a scrollozás szaggat.
    Az ablakváltások is elég lassuak , valami nagy gáz lehet.. Ujraforgattam , a xorg-servert xorg-x11-et , qt-t mondjuk meg nem. Nem tudom mi lehet.....

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Sipi

    addikt

    Instabil rendszert használsz? (~x86) Csak mert most jelent meg az új Xorg, ami sok mindenben lényeges változást hozott. A bináris driverek pl. nem biztos, hogy működnek, az eddigi input-output driverek is újraforgatást igényelnek.

    Az xorg-server 1.4-es verziójú. Nézd meg, mi van fent. Az x-es csomagokból javaslom, mindegyiknél kapsold ki a packages.keyword-ben, ha instabilra van állítva, és downgrade-elj az 1.3-as xorg-server és függőségeire.

    Nézd meg az xorg logját, valamint a home mappában a .xsession-errors fájlt, hátha van benne valami. Első blikk pl.: valami miatt nincs bekapcsolva (vagy nem is lehet) a Render extension.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • Batman

    őstag

    Nem nyert, xorg-server-ből 1.3-as van fent.

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Sipi

    addikt

    Akkor passz...

    Gondolom, konzolban nem lassú a rendszer. Ilyen szaggatást nekem két dolog szokott okozni: a videodriver nem gyorsítja a Render és Composite funkciókat (Xorg vagy driver-hiba), illetve a kernelből kimaradt egy-két dolog. Ez utóbbit viszont nehéz eldönteni, a legújabb kernelek újdonságaitól csak pislogok.

    Ja, azt nézd meg, az xvinfo, glxinfo mit ír ki! Van-e egyáltalán XVideo extension, Direct Rendering.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • dr_strange

    senior tag

    elmaradt egy eselect update opengl-nvidia?

    bár nem tudom, az okoz-e ekkora lassulást 2D műveletekben

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

  • Batman

    őstag

    öteletem sincs semmi..... :(

    xvinfo
    X-Video Extension version 2.2
    screen #0
    Adaptor #0: ''ATI Radeon Video Overlay''
    number of ports: 1
    port base: 65
    operations supported: PutImage
    supported visuals:
    depth 24, visualID 0x23
    depth 24, visualID 0x24
    depth 24, visualID 0x25
    depth 24, visualID 0x26
    depth 24, visualID 0x27
    depth 24, visualID 0x28
    depth 24, visualID 0x29
    depth 24, visualID 0x2a
    number of attributes: 22
    ''XV_DEVICE_ID'' (range 0 to -1)
    client gettable attribute (current value is 108)
    ''XV_LOCATION_ID'' (range 0 to -1)
    client gettable attribute (current value is 109)
    ''XV_INSTANCE_ID'' (range 0 to -1)
    client gettable attribute (current value is 110)
    ''XV_DUMP_STATUS'' (range 0 to 1)
    client settable attribute
    ''XV_SET_DEFAULTS'' (range 0 to 1)
    client settable attribute
    ''XV_AUTOPAINT_COLORKEY'' (range 0 to 1)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_COLORKEY'' (range 0 to -1)
    client settable attribute
    client gettable attribute (current value is 30)
    ''XV_DOUBLE_BUFFER'' (range 0 to 1)
    client settable attribute
    client gettable attribute (current value is 1)
    ''XV_OVERLAY_ALPHA'' (range 0 to 255)
    client settable attribute
    client gettable attribute (current value is 255)
    ''XV_GRAPHICS_ALPHA'' (range 0 to 255)
    client settable attribute
    client gettable attribute (current value is 255)
    ''XV_ALPHA_MODE'' (range 0 to 1)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_BRIGHTNESS'' (range -1000 to 1000)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_CONTRAST'' (range -1000 to 1000)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_SATURATION'' (range -1000 to 1000)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_COLOR'' (range -1000 to 1000)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_HUE'' (range -1000 to 1000)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_RED_INTENSITY'' (range -1000 to 1000)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_GREEN_INTENSITY'' (range -1000 to 1000)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_BLUE_INTENSITY'' (range -1000 to 1000)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_SWITCHCRT'' (range 0 to 1)
    client settable attribute
    client gettable attribute (current value is 0)
    ''XV_GAMMA'' (range 100 to 10000)
    client settable attribute
    client gettable attribute (current value is 1000)
    ''XV_COLORSPACE'' (range 0 to 1)
    client settable attribute
    client gettable attribute (current value is 0)
    maximum XvImage size: 2048 x 2048
    Number of image formats: 8
    id: 0x41424752 (RGBA)
    guid: 52474241-0000-0010-8000-00aa00389b71
    bits per pixel: 32
    number of planes: 1
    type: RGB (packed)
    depth: 32
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    id: 0x0
    guid: 52474200-0000-0010-8000-00aa00389b71
    bits per pixel: 24
    number of planes: 1
    type: RGB (packed)
    depth: 24
    red, green, blue masks: 0xff0000, 0xff00, 0xff
    id: 0x54424752 (RGBT)
    guid: 52474254-0000-0010-8000-00aa00389b71
    bits per pixel: 16
    number of planes: 1
    type: RGB (packed)
    depth: 16
    red, green, blue masks: 0x7c00, 0x3e0, 0x1f
    id: 0x32424752 (RGB2)
    guid: 52474200-0000-0010-8000-00aa00389b71
    bits per pixel: 16
    number of planes: 1
    type: RGB (packed)
    depth: 16
    red, green, blue masks: 0xf800, 0x7e0, 0x1f
    id: 0x32595559 (YUY2)
    guid: 59555932-0000-0010-8000-00aa00389b71
    bits per pixel: 16
    number of planes: 1
    type: YUV (packed)
    id: 0x59565955 (UYVY)
    guid: 55595659-0000-0010-8000-00aa00389b71
    bits per pixel: 16
    number of planes: 1
    type: YUV (packed)
    id: 0x32315659 (YV12)
    guid: 59563132-0000-0010-8000-00aa00389b71
    bits per pixel: 12
    number of planes: 3
    type: YUV (planar)
    id: 0x30323449 (I420)
    guid: 49343230-0000-0010-8000-00aa00389b71
    bits per pixel: 12
    number of planes: 3
    type: YUV (planar)



    glxinfo
    name of display: :0.0
    Xlib: extension ''XFree86-DRI'' missing on display '':0.0''.
    display: :0 screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
    client glx vendor string: ATI
    client glx version string: 1.3
    client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
    GLX version: 1.2
    GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
    OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ----------------------------------------------------------------------
    0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
    0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
    0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
    0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
    0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
    0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
    0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
    0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
    0x43 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • dr_strange

    senior tag

    Ja, hogy Ati. Ahhoz sajnos nagyon nem értek...

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

  • brazso

    tag

    Direct rendering nincs bekapcsolva, de gondolom nem opengl-es video drivert használsz az mplayer-rel. Beraknál egy /var/log/Xorg.0.log kimenetet is?

    Unus pro omnibus, omnes pro uno

  • Batman

    őstag

    Attol hogy nincs direct rendering a 2D-s műveleteknek nem szabadna akadni.
    A log elég hosszu lenne, tudom hogy vannak olyan oldalak ahova logokat , txt-ket lehet feltenni és azt megosztani, csak nem tudom a címét. Esetleg valaki tud ilyet?

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Sipi

    addikt

    Ez elég összetett. Úgy tudom, a 2D műveletek gyorsításához (XRender) sem árt DRI. Ha Composite-t használsz (átlátszóság, árnyék), ahhoz is.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • brazso

    tag

    Az is jó, ha elküldöd email-ben. A notebook-omon sincs direct rendering, mivel nem tudtam összehozni a régi trident videokártyára, de nincs vele semmi gondom 2D-ben. (Mondjuk jó 2 hónapja frissítettem utoljára, ráadásul stabil ágat használok.)

    Unus pro omnibus, omnes pro uno

  • Batman

    őstag

    elküldtem mailben.

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Batman

    őstag

    Nem tudjátok mi van a gentoo forummal, napok óta halott!

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Sipi

    addikt

    Átállás van náluk, de nyolcadikán indult, azt írták, két napig tart. Valószínűleg ott sem jött össze. :D

    [link]

    Sipi

    [Szerkesztve]

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • Batman

    őstag

    Mostanában divatt lett az átállás, lehet nekem is át kellene állnom valahova máshova.... ;] :DDD

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Batman

    őstag

    A komplett rendszer lassulásra nem találtam magyarázatot, lehet vissza kellen állnom teljesen stabil ágra, de az nem kis melo lenne , minden egyes csomagot újra tenni. :o

    A másik lehetőség hogy várok , folyamatosan frissítem a rendszert és majd csak elmúlik. :D

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • brazso

    tag

    UTF-8-asítják a fórum alatti adatbázist. A packages.gentoo.org meg már vagy 1 hónapja nem elérhető, azon is dolgoznak. Türelem :)

    Unus pro omnibus, omnes pro uno

  • dr_strange

    senior tag

    http://www.gentoo.org/proj/en/forums/forum-downtime200709.xml

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

  • Sipi

    addikt

    Én mindig a második lehetőséget követem. :) Időnként akadnak nem várt furcsaságok, de hamar megoldódnak. Ha nem, a dmesg/Xorglog/xsession error megmondja a frankót.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • Batman

    őstag

    Hát már észre se veszem filmek közben az akadást, hihetetlen az emberi agy mennyire alklamazkodó képes , a nem kívánt infokat ignor-álja , így szinte folyamatos képet látok! ;]

    Scrollozás helyett meg page down-up , az még nem akad.... :DDD

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Sipi

    addikt

    Nekem mostanság játék, film alatt mindig csontra fagyott a gép. Egyszer sikerült felélednie, immár grafikus felület nélkül. S a dmesg-ben komplett hibaüzenet, az nVidia README-jében pedig ugyanezen hibára komplett megoldás. Azóta nem fagy.
    Valószínűleg a driver szarakodik, de ehhez logokat kell nézni. A DRI hiánya official Ati és nVidia alatt kvázi minden gyorsító funkció hiányát is jelenti. Mindenképpen próbáld DRI-re bírni. Ha jól láttam, bináris Ati-drivert használsz.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • zfarkas

    senior tag

    Nekem is halál lassú volt néha a gépem, érdekes dolog jött elő, a kernel kacpid és kacpi_notify processzei valamiért néha-néha 100% CPU-t használtak. Ha minden igaz, valami a thermal ACPI modullal kapcsolatos gond van, túl sok időm nem volt utána járni.
    Én annyit tettem ellene, hogy 'renice 19 -p `pidof kacpid kacpi_notify`'.
    Volt még egy gondom, Opera + Flash nem nagyon komálták egymást, néha elkezdett malmozni az Opera plugin cleaner, vagy micsoda, esetleg csontra fagyott a teljes Opera. Szóval dög lassú lett. Ezért felraktam a Flashblock-ot: [link].

    Általában nézd meg 'ps xau'-val (régóta futó processzek CPU használatáért) és 'top'-al (aktuális CPU használatért), hogy mik eszik a procidat, onnan érdemes tovább kutakodni.

    Raw Dark Pure

  • Sipi

    addikt

    Ja, tényleg, az örök szerelmem: ACPI és IRQ-kiosztás... nVidia/AMD alapú gépeim vannak/voltak, azokon siralmas a chipset. Furcsa fagyásoknál, lassulásnál érdemes kipróbálni a következő kernel-kapcsolókat pl. a grub.conf-ban, bootnál: noapic, pci=biosirq, pci=noacpi, esetleg nolapic, pci=nommconf. Van, hogy a modern gépeken totál rosszul lesznek kiosztva a megszakítások, ugyanazt kapja pl. a hálókártya és a vga.

    Flash minden böngésző alatt trágya. :( A plugin cleaner nekem mindig lefogta a gépet, akkor is, ha nem volt plugin betötve (nem töltöttem be egy oldalt sem).

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • Batman

    őstag

    Hellosztok!

    frissitetem a rendszert es belefutottam egy olyan hibaba, hogy nem tudok ekezetet irni.
    ugy emlekszem egyszer mar volt ilyen problemam de tokre nem emlekszem mi volt a megoldas.

    esetleg valaki?

    kszi

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Sipi

    addikt

    Az xorg-server megint evolúcióját éli, némi gonddal. A /usr/share/X11/xkb mappában nem hozza létre a compiled symlinket, aminek a /var/lib/xkb-ra kell mutatnia. Hozd létre, és jó lesz nagyon. :)

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • Batman

    őstag

    udv

    ezt hol olvastad nekem nem oldotta meg a probemat, kaphatok linket.
    koszi

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Sipi

    addikt

    Gőzöm sincs... Nekem megállt a teljes xkeyboard extension, keresgéltem, aztán találtam pár oldalt. :B Nézd meg az xorg logot, mit mond, mit hiányol.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • Batman

    őstag

    Hello!

    Tudsz dobni egy ls-t hogy neked mi van a /var/lib/xkb mappadban?

    koszi

    A Rák ellen az Emberért a Holnapért! - "..ez csak azt bizonyítja, hogy a Firefoxtól maximum a pöcsöd érzed nagyobbnak, de ugyanolyan hüje maradsz a számítógéphez..." by moonman

  • Sipi

    addikt

    Lényegében semmi. Egy .keep* fájl, meg a README.compiled. Itt nem szokott semmi lenni, rövid időre a compiled xkeyboard map bekerülhet.

    ln -s /var/lib/xkb /usr/share/X11/xkb/compiled

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • morad777

    csendes tag

    Sziasztok!

    A segítségeteket szeretném kérni!
    Egy linuxos /gentoos/ mail-szervert szeretnék összerakni, egy 30-40 fős cég számára, de nem igazán tudom, hogy merre induljak.
    Gentoo telepítése oké, de a levelelző kiszolgálóban kéne segítenetek.
    Fontos az ingyenesség és hogy jó spam szűrője legyen.

    Szeretném ha adnátok egy-két tippet ezzel kapcsolatban.
    -Milyen szoftvert érdemes használni?
    -Mennyire nehéz a telepítése/konfigurálása/karbantartása?
    -Kinek mi a tapasztalata ezzel kapcsolatban?
    -Esetleg egy két linket, hogy merre keresgéljek.

    Előre is köszönöm a segítséget!

    morad777

    morad

  • birno

    őstag

    Sziasztok!

    Még kezdő linuxos vagyok, kb. 2 hónapig használtam Xubuntut, most kb. 2 hete Debian-t, de rájöttem, hogy tényleg nem való desktop rendszernek, zavar, hogy nagyon régi csomagok vannak csak benne.

    Gondolkozom a gentoo-n, csak nem tudom mennyire törne bele a bicskám.
    Ahogy olvasgattam a telepítés sem egyszerű, bár ha első körben live-ről nyomnám fel akkor már egy kész rendszert kapnék, igaz?
    Mennyiben tér el a csomag kezelése egy Debian alapú rendszertől?
    Főleg úgy értve, hogy automatikusan szedi-e a függőségeket vagy azokat külön kell vadászni?
    Gentoo esetében a függőséget a fordításhoz szükséges fejlesztői csomagok jelentik gondolom, igaz?

    Még a frissesség kérdése érdekelne.
    Azt olvastam, hogy a Gentoo-ban mindig a legfrisebb csomagok vannak.
    Ez úgy értendő, hogy ha mondjuk megjelenik egy új kernel,az ablakkezelő egy új verziója vagy mondjuk egy új VLC, akkor annak a forrása pár napon belül felkerül a repoba majd onnan le lehet szedni és a Portage lefordítja a gépemhez mérten?
    Nem kell egy újabb kiadásra várni az oprendszerből vagy simán csak arra, hogy csináljanak egy bináris-t az adott disztóhoz?
    Előre is köszi a tanácsaitokat! :)

  • dr_strange

    senior tag

    Hát, mindenekelőtt állj neki olvasni, pl. itt:

    www.gentoo.org/doc/hu

    De szeretettel látunk a portálunkon is:

    magenta.linuxforum.hu

    A telepítés valóban nem triviális, de ha pontosan követed a Gentoo Kézikönyvet (ami kitűnő) és ésszel csinálod, sikerülni fog.
    Csomagkezelés: a függőségeket automatikusan kezeli, mert azok a telepítést leíró ebuild fájlokban (ha úgy tetszik, ezek felelnek meg a debeknek, persze igazából nem) fel vannak sorolva és a portage behúzza őket. Fejlesztői fájl nincsen, merthogy forrásból települ minden.

    Repo sincsen. Az ebuildek karbantartói folyamatosan fejlesztik az ebuildeket, ha kijön egy új verzió, updatelik/átírják az ebuildet. Az ebuild alapján a portage a megadott mirrorok valamelyikéről letölti a forrást, lefordítja és telepíti a csomagot.
    Kiadások nem igazán vannak. A telepítőCDkből készül úgy félévente új verzió, hogy aki nulláról telepít, a legfrissebb alaprendszert kapja. A már telepített rendszer folyamatosan frissíthető egyetlen paranccsal, nem kell kiadásokra várni.
    De mielőtt belevágnál, azért még olvass és kérdezz, mert ennél még több is van a Gentooban.

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

  • birno

    őstag

    Olvasgattam már múltkorjában, VMWare alá el is kezdtem telepíteni a leírás alapján, csak aztán abbamaradt a dolog, mert más foglalt le.
    Nagyon tetszik benne, hogy ilyen jól van dokumentálva, meg olvastam valahol, hogy mire az ember feltelepíti és működő rendszert kovácsol belőle, addigra "kiismeri" a Linux lelkivilágát.Ezt valahogy én is így éreztem a telepítés közben, tök frankón meg lehet tanulni hogyan épül fel a rendszer.

    Most egy kicsit összezavartál. Amikor forrásból telepítetek valamit mondjuk Debian alatt és a "./configure" résznél hiányol valamit akkor mindig az adott csomag development verzióját kell telepítenem.A fejlesztői csomag nem egyenlő a forrással? :U
    S ha mondjuk valami nincs meg az ebuild-ekben és leszedem a progi forrását, akkor azt itt is "kézzel" kell lefordítanom vagy az emerge megcsinálja és telepíti?
    Kb. úgy gondolom mint amikor repoban nincs meg valami, de mondjuk a progi oldalán van .deb csomag és azt a "dpkg -i"-vel pakolom fel.

    Tehát akkor ezek az ebuild-eket úgy kell elképzelni mint egy szöveges fájlt ami a progi nevet, verziót és az elérhető mirrorokat tartalmazza, mondjuk naponta csekkolja, hogy van-e új ebuild, ha igen jelzi és amennyiben kell, a fejlesztők honlapjáról szedi le a forrást és így "kerüli meg" a repokat?

    Még egy buta kérdésem lenne, mi a helyzet a stabilitással és a biztonsággal?
    Anno én Debian-t tanultam előszőr és mindig azt hajtogatták, hogy az egy atom stabil rendszer, méghozzá azért, mert nem a legújabb csomagokat használja, hanem a régebbi már befoltozott, kijavított stabil verziókat.
    Vagy ezt a valamit valamiért elvén képzeljem el?

    Különben közben éjjel lejött live cd, majd azt elkezdtem nézegetni vagy felrakom egy külön vinyóra és tesztelgetem.

  • dr_strange

    senior tag

    "Most egy kicsit összezavartál. Amikor forrásból telepítetek valamit mondjuk Debian alatt és a "./configure" résznél hiányol valamit akkor mindig az adott csomag development verzióját kell telepítenem.A fejlesztői csomag nem egyenlő a forrással?"

    -- amennyire emlékszem rpm-es időkből, a development csomagok tartalmazzák azokat a header meg include stb. fájlokat, amelyek a fordításhoz szükségesek, a bináris futásához meg nem. Mivel Gentoo alatt kevés kivétellel _minden_ eleve forrásból telepedik, nincs olyan, hogy fejlesztői csomag. Ha kiadod az emerge akármi parancsot, a portage letölti a forrást, lefordítja és kész.

    "S ha mondjuk valami nincs meg az ebuild-ekben és leszedem a progi forrását, akkor azt itt is "kézzel" kell lefordítanom vagy az emerge megcsinálja és telepíti?
    Kb. úgy gondolom mint amikor repoban nincs meg valami, de mondjuk a progi oldalán van .deb csomag és azt a "dpkg -i"-vel pakolom fel."

    -- persze, megteheted; de jobban jársz, ha a) magad írsz ebuildet hozzá (egyszerűbb csomagoknál nem egy ördöngösség) b) vadászol egy 3rd party ebuildet valamelyik nemhivatalos "repóból" (Gentooéknál overlaynek hívják); ennek megvan az az előnye, hogy a csomagkezelőd tudni fog a feltelepített csomagról.

    "Tehát akkor ezek az ebuild-eket úgy kell elképzelni mint egy szöveges fájlt ami a progi nevet, verziót és az elérhető mirrorokat tartalmazza, mondjuk naponta csekkolja, hogy van-e új ebuild, ha igen jelzi és amennyiben kell, a fejlesztők honlapjáról szedi le a forrást és így "kerüli meg" a repokat?"

    -- Igen, az ebuild tulajdonképpen egy bash script, ami változókat és függvényhívásokat tartalmaz, és leírja a fordítás-telepítés menetét. Magától nem csekkol semmit, a felhasználótól függy, hogy milyen sűrűn szinkronizál (frissíti az ebuildatabázist a gépén) és frissíti a csomagjait - mindez akár egyetlen paranccsal megtehető.
    Legegyszerűbb, ha bekopizok egy egyszerű ebuildet illusztrációképpen:

    # Copyright 1999-2006 Gentoo Foundation
    # Distributed under the terms of the GNU General Public License v2
    # $Header: ghamachi-0.8.1.ebuild $

    inherit eutils

    # gHamachi GUI
    GTK2_VER="0.8.1"

    DESCRIPTION="gHamachi is a GUI for the Hamachi tunneling software package."
    HOMEPAGE="http://www.penguinbyte.com/software/ghamachi/"
    LICENSE="as-is"
    SRC_URI="http://purebasic.myftp.org/files/3/projects/${PN}/v.${PV}/gHamachi_${PV}.tar.gz"
    SLOT="0"
    KEYWORDS="~x86 ~amd64"

    RESTRICT="nostrip nomirror"
    DEPEND="net-misc/hamachi
    =x11-libs/gtk+-2*"

    src_unpack() {
    unpack gHamachi_${PV}.tar.gz
    mv ${WORKDIR}/README ${WORKDIR}/README.gHamachi
    }

    src_install() {
    einfo "Installing GUI"
    insinto /usr/bin
    insopts -m0755
    doins ${WORKDIR}/ghamachi
    dodoc ${WORKDIR}/README.gHamachi
    }

    Stabilitás: választhatsz. Megteheted, hogy csupa stabil csomagból építed fel a rendszered, de ha úgy gondolod, csupa legújabb, még nem egészen stabil csomagból is, sőt, akár csomagonként szabályozhatod, melyiket szeretnéd.

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

  • birno

    őstag

    Köszi a felvilágosítást, ez nagyon jól hangzik, kipróbálom s meglátjuk mi lesz. :)

  • dr_strange

    senior tag

    Hajrá. De _őszintén_ ajánlom, előtte olvass kicsit a Gentoo rendszer- és Portage-felépítéséről, ha telepítesz, ne a grafikus, hagyományos konzolos telepítést válaszd (még ha vonzóbbnak is tűnik a gtks kattintgatás) és ha telepítesz, és módod van rá, nyomtasd ki és tedd magad elé a Gentoo Handbook telepítési fejezeteit és értelmezd. Úgy valóban tanulási folyamat lesz, és még ha hiba is csúszik a telepítésbe (ami előfordulhat), könnyebben lehet majd feltárni a hiba lehetséges okát.

    Elakadás esetén MaGenTán vagy itt biztos lesz, aki előbb-utóbb segít.

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

  • birno

    őstag

    Közben próbálkoztam a felrakással, a grafikussal(nem olvastam előtte a hsz-ed), networkless módban, de a live cd is eleve érdekesen viselkedett, nem ismerte fel normálisan az nvidia kártyát, legalábbis vesa drivert rendelt hozzá, weboldalak lapozása közben szaggat az egész, fél perc mire egy "page down" végbemegy, a telepítő közben a legördíthető menüknél ugyanez volt, telepítés után a grub-ot nem is rakta fel magától.
    emerge-el próbáltam az mc-t felrakni, de nem sikerült, nem tudott szerverekhez csatlakozni, miközben a ping ment.

    Szerintem az lesz, hogy jővőhéten a minimal verzióból próbálom meg felépíteni a kézikönyv alapján, kinyomtatni sajna nem tudom, majd a links-el nézem közben.
    Csak annyi a gáz vele, hogy rengeteg idő lesz mire feltelepül a fordítások miatt, főleg egy grafikus felülettel együtt.

  • dr_strange

    senior tag

    Nem gáz az, hanem a Gentoo ára. De hát telepíteni jó esetben egyszer kell. Én pl. a mostani rendszerem 2006 márciusában telepítettem, az előző meg vagy négy évet ment, frissítgetve.

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

  • Sipi

    addikt

    Tanács: NAGYON fontold meg, milyen USE flageket kapcsolsz be. Totál felesleges mindig mindent, így csak nagyméretű binárisokat kapsz, melyeknek kiskmillió "dll"-je lesz. Lassú, nehézkes lesz a géped. Ráadásul rengeteg dolgot kell fordítanod.

    Főleg az elején érdemes a -X kapcsolót berakni, mert az alaprendszerhez nem kell grafikus felület, ezzel is időt nyersz. Utána pedig ötször átgondolod, kell-e pl. openexr- vagy musepack-támogatás. Ha nem tudod, mi az, inkább ne. :)
    Hasonló módon felesleges az adatbázis-támogatás (odbc, mysql, postgresql). Otthoni gépen maximum 1-2 program lehet, aminek tényleg kell ilyen, de akkor meg már sqlite, ha választható.

    Egyébként a legtöbb időt a USE flagek beállítása fogja jelenteni. Nekem ma már, hogy tudom, hogyan kell csinálni, az alaprendszerem egy minimális grafikus felülettel egy nap alatt megvan. Az X is hamar települ. A Gnome, KDE, gcc és glibc az, ami sok idő.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • birno

    őstag

    Olvasgattam a kézikönyvet és épp attól tartok, hogy a USE flageket nem fogom tudni használni, legalábbis elsőre nem fog összejönni egy épkézláb rendszer.
    Viszont meg akarom próbálni, mert nagyon tetszik a rendszer felépítése, meg a lehetőségei.

    Az ugye nem megoldható, hogy egy már működő rendszer alól kezdjem a Gentoo telepítését?
    Csak mert úgy egyszerűbb lenne googlizni és keresgetni telepítés közben mit hogyan csináljak.
    Olyasmi kellene mint ha VMWare alatt csinálnám, csak a saját hardvereimet ismerné fel.
    Bár gondolom ilyen nincs. :)

  • Sipi

    addikt

    Miért ne lenne? Olvass csak bele jobban a kézikönyvbe! :)
    A telepítés első lépései pl. a merevlemez előkészítése, illetve a rendszer letöltése. Bármilyen futó Linux alatt tudsz partícionálni... Utána chroot-tal átváltasz az előkészített Gentoo-ba. Ez is megy másik Linux alatt: az egyik terminálon a telepítés alatt lévő Gentoo fut, a többin az eredeti Linux. Csak akkor kell majd rebootolni, amikor az új kerneled is elkészült, és már a kész Gentoo-t akarod izzítani.

    Egyébként a telepítési kézikönyv a telepítő cédén is fent szokott lenni, másik terminálban én is azt kukkolom links2 vagy lynx karakteres böngészővel.

    Nyugi, nekem is csak a kb. harmadik rendszerem lett épkézláb, előtte minden szart beletettem... Egyébként semmi gond. Egy Gentoo-t tényleg nem tudom elképzelni, mikor kellene nulláról újratenni. Ha rájössz, nem kell egy rakás USE flag, akkor kikapcsolod, és az emerge parancs --newuse kapcsolójával újrahúzod azokat a csomagokat, amelyeknél megváltoztak a beállítások. És onnantól olyan, mintha eredetileg így tetted volna fel. (Azt leszámítva, hogy esetleg fenn lesz a gépen pár program, könyvtár, amire nincs szükség többé. De mindegy, max. a helyet fogja.)

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • birno

    őstag

    Valóban igazad van, de nekem még a kernel előtt kell váltani, ugyanis a genkernel-t fogom használni, sajna még kernel fordításban nem vagyok otthon.
    Köszi a tippet! :R

    A USE flageket, meg majd lehet beírom ide miután összeállítottam őket, meg leírom nagyjából miket akarok használni, hátha nem csak harmadszorra jönne össze. :)

  • birno

    őstag

    Ez mission impossible.
    Már vagy ötször nekiálltam átnézni a flageket, de legtöbbről fogalmam sincs, hogy micsoda vagy hogy kell-e.
    Mi van ha csak az alap 2007.0-ás desktop profillal csinálom?
    Nagyon gáz lesz?
    Meg pl. XFCE-vel akarom majd használni, ahhoz mi kell?
    Csak az X?
    Mert kde, gnome flag van, de xfce nincs. :)

  • dr_strange

    senior tag

    Egyszer nekiálltam egy make.conf generáló szkriptnek, ami lépésről lépésre végigviszi a kezdő felhasználót a make.conf leggyakoribb funcióin. Nem fejeztem be (a FEATURES változó pl. nem került bele), de kezdetnek megteszi, USE flagekben segíthet:

    http://magenta.linuxforum.hu/index.php?q=node/1136

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

  • birno

    őstag

    Köszi, közben azonban felraktam az alap flag-ekkel, próba telepítésnek jó lesz.
    Elsőre működöképesnek is tűnik, bár azt mondjuk nem értem, hogy beállítottam egy statikus IP-t az /etc/conf.d/net fájlban, majd rc-update-el hozzáadtam a futási szintekhez akkor miért nem használta, fel kellett raknom egy dhcp kliens-t, hogy legyen netem.

    Meg pl. nyomtam egy "emerge links" parancsot, erre leakar szedni 176 csomagot. :Y
    Aztán ahogy néztem a --pretend kapcsolóval a xorg-hoz való csomagok kellettek neki, de nem vágom a links-hez az minek?

    Most visszajöttem Debian alá, szerintem inkább innen fogom chroot környezetből felrakni az X-es cuccokat, mert egy darabig el lesz foglalva a fordításokkal.
    Desktop-ot a dokumentációkban található sorrendben érdemes felrakni, igaz?
    Vagyis elöszőr Xorg, majd nvidia driver és végül az ablakkezelő.

    Ahogy néztem az nvidia drivernél bele kell piszkálni a kernel konfigba.
    Ha ezt megteszem egy sima "make menuconfig"-al, majd elindítom a genkernel-t akkor az általam módosított .config-ot fogja használni, igaz?
    Nem ír át benne semmit?

  • Sipi

    addikt

    emerge gentoolkit
    Ezután lesz egy euse parancsod:

    euse -i flag

    kiírja, mire való az adott flag, valamint hogy globális (make.conf-ban kell állítani) vagy lokális (pár csomagra érvényes, a /etc/portage/package.use fájlban kell állítani).

    Az XFCE-nek nincs külön flagje. A kde, gnome flag nem igazán azt adja meg, hogy neked kde kell, hanem hogy egy adott programhoz készítsen-e kde-támogatást. Ehhez persze a kde nagy részét fel kell rakni.

    Telepítés elején a links azért akart annyit emergélni, mert megadtad, hogy X támogatással forduljon. Ha nem kell, akkor a /etc/portage/package.use fájlban kapcsold ki a links-re az X támogatást, vagyis írd be ezt a sort:

    www-client/links -X

    Mivel a make.confban be van kapcsolva az X, azon programok, melyeknek van X-támogatsa (pl. egyszerűbb grafikus felülete, vagy kihasznál valamit az Xorgból), ezzel fordulnak. A links-nél viszont kézzel kikapcsoltad, tehát jelenleg ennél az egynél nem veszi figyelembe, a lefordított links nem támogatja az X-et.

    Az xfce-hez elég az xfce4 metacsomagot emergélni. Ez nem igazi csomag, csak az van benne, hogy egy működő XFCE-felülethez milyen csomagokat telepítsen.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • Sipi

    addikt

    Net: ellenőrizd, hogy tényleg jó parancsokat írtál bele, s azt is, hogy a megfelelő interfészhez! Létezik az adott ethX interfész? Megcsináltad a szimbolikus linket a net.lo-ra? DHCP kliens két esetben kellhet: direkt azt adtad meg, vagy nem adtál meg semmit az adott interfészhez. Ilyenkor a Gentoo automatikusan úgy veszi, hogy DHCP-t használsz.

    A links-et előbb írtam. Ha a pretenddel meg is nézted, láthattad: be van kapcsolva az X flag, vagyis X-támogatást kérsz. Ehhez fel kell raknia. :)

    Desktop: igen, ilyen sorrendben.

    Nvidia: nem emlékszem, hogy különösebben piszkálni kellene. Pár opció kell a drivernek, de olyan alapdolgok, amelyek szerintem a genkernellel is beállítódnak.
    A genkernel simán futtatva felülírja a .configot, hiszen előre beállított dolgokat készít. Viszont meghívhatod a parancsot a --menuconfig kapcsolóval is, ekkor elkezd molyolni, majd ő maga meghívja a menuconfigot, kézzel bekapcsolhatod, ami kell, kilépsz, és ez alapján folytatja a kernel-generálást.

    Sipi

    Mont-joie! Saint Denis! Je trépasse si je faiblis!

  • birno

    őstag

    euse: Azt megtaláltam a dokumentumok között is, hogy mire való a flag, de sokszor fogalmam sincs, hogy az mégis mit csinál meg, hogy kell-e, pl.:

    "avahi Add avahi/Zeroconf support
    bash-completion Enable bash-completion support"

    Ezek sajna semmit nem mondanak, így mondjuk valszeg nem is kellenek. :)

    links: Most már kedzem kapisgálni hogyan működnek a flagek, ez egy jó példa volt.
    Ezeket a flageket írja hozzá: USE="X gpm jpeg png sdl ssl tiff unicode -directfb -fbcon -javascript -livecd -svga"
    Ebből mondjuk a jpeg, png sem igazán kell ha jól gondolom, mivel képeket úgysem jelenit meg, igaz?
    Azt meglehet tudni, hogy egy adott csomaghoz milyen flagek rendelhetőek?
    Mert ha jól látom ilyenkor csak azokból válogatja össze ami a make.profiles vagy a make.conf-ban szerepel.

    Net: Valóban elírtam valamit, sorry. :B
    Szimbolikus link a net.lo-ra? Ilyesmi csak a "Creating extra initscripts" résznél szerepelt ha több hálozati csatolom lenne, de nekem csak egy van, így csak net.eth0-át csináltam.

  • dr_strange

    senior tag

    "Azt meglehet tudni, hogy egy adott csomaghoz milyen flagek rendelhetőek?
    Mert ha jól látom ilyenkor csak azokból válogatja össze ami a make.profiles vagy a make.conf-ban szerepel."

    Nem, az euse ill. az "emerge -v csomag" az összes, az adott csomagra érvényes flaget kilistázza, értelemszerűen ami előtt mínuszjel áll, az nincs bekapcsolva, a többi meg igen. A többi jelöléshez: man emerge.

    JRR Tolkien nyelvei - aglardh.middangeard.org.uk

Hozzászólok Aktív témák